Back to overview
Degraded

Payment API increased latency

Apr 16 at 04:56pm BST
Affected services
API

Resolved
Apr 16 at 09:42pm BST

We are now seeing regular latency with the search API.
We will continue to monitor and co-ordinate with Stripe on a root cause.

Updated
Apr 16 at 06:57pm BST

Stripe has acknowledged an issue on their end causing data availability delay for the Search API.

They are aware of the issue and are seeing some recovery, though their engineering teams continue to actively investigate the root cause.

Created
Apr 16 at 04:56pm BST

We are noticing a delay in responses from our payment api to client endpoints.
This is currently causing issues when displaying new invoices that are generated. We are investigating the issue and will update when we have further information.